Categories
VSCP

Phosphorus 15.0.0

The VSCP Daemon Phosphorus 15.0.0

It is my pleasure to announce that it is now time for release 15.0.0 Phosphorus of the VSCP & Friends package. From version 15 each component will be shipped separately and first out is the VSCP daemon, the server for the VSCP IoT system.

The code for the full VSCP software framework has been fully rewritten and is now C++ standard based. There is no dependencies on external frameworks at all anymore. License is MIT.

The goals for the software part of the project has changed.

First: node-red and similar high level tools will be used for user interface and scheduling tasks.

Secondly: MQTT is now a central part of VSCP and the VSCP daemon is dependent on it to work. VSCP is a good fit for MQTT.

Third: much of the functionality that previously was built into the VSCP daemon is now available as drivers. This is true for the tcp/ip interface, the web server, the two websocket servers and the rest interface and some other functionality like remote variables that will follow.

This release in fact make the VSCP daemon a low level interface to a MQTT based system. A low end driver can be hooked on to the VSCP daemon and the nodes handled by it (if any), or driver embedded functionality, can connect through the VSCP daemon and interface to a MQTT based system.

VSCP stands for the Very Simple Control Protocol, but is nowadays, with it’s existence for more than two decades, more of an IoT/m2m framework. The most important part is still to make sure that a measurement, command etc, is interpreted at the source the same way as it was expected to be by the originator.

The VSCP daemon can be downloaded here. Packages for Debian based systems (also Raspberry Pi) is available. Windows install files will be available later.

If you want to know more about the VSCP framework the project home page is a good start. Most docs are here and especially for the VSCP daemon here. If you want to discuss VSCP this is the place to do so. If you find bugs or problems issue a ticket here

Of course I need to thank my sponsors at this stage. Your support has been a great help.

Enjoy!
/Ake Hedman

2 replies on “Phosphorus 15.0.0”

hi Ake looks good….. a question: I use Ubuntu 20.10 64 bit on an RPI-4 which deb should I use to install Phosphorus. Will certainly have a good look at it as I use MQTT and Node-red as well. Best regards from Alkmaar.
/Henk

I have not tested the Ubuntu – Raspberry pi combo. The rpi install may work but is 32-bit to work on all Rpi’s, so best would be to build and install it on your own.

Hope everything is terrific in Alkmaar.

Leave a Reply to alkmaarder Cancel reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.